Pasting files for ed is dropping a lot of characters

In mudos for our mud, I commonly paste in large files since we don’t have ftp access on our production mud. These pastes have always worked perfectly. In the fluffos mud we are now trying to get working, pasting even relatively small files isn’t working, and a lot of characters and lines are just absent.
The editor being used in both cases is ed.

tl;dr It seems a large number of characters are being dropped when a large amount of text is sent to the fluffos mud.
Am I doing something wrong?

There are currently some limits on Line length and input buffers, we could raise those limit, but how big is your typical files?

The file I was updating via ed last night is 16,011 bytes, but this is a small file compared to ones I’ve had to upload in the past.
Last week in our production mud, I had to upload a 69,316 byte file via ed, and that worked perfectly fine.
Are these too large for fluffos currently?

can you file a github issue and I will see how I can raise the limit to about 128K instead.

Issue created at:
Thank you!